Problem upgrading to 0.9

Aug 12, 2011 at 2:42 PM

I had a problem upgrading to 0.9 and posted the details here: http://orchard.codeplex.com/discussions/268852

Coordinator
Aug 12, 2011 at 2:50 PM

I found the issue, in the Upgrade code, there was a type mismatch for DebugMode. It should be a string. The bug only occurs for already installed versions. If you change the UpgradeFrom1() DebugMode type to bool, it should work.

Aug 12, 2011 at 5:48 PM

I'm a little confused (well a lot actually), is this fixed in 0.9.1?

When I upgraded to 0.9.1 I had the same error, so I _assume_ that I need to "change the UpgradeFrom1() DebugMode type to bool" ?

Which file is this located in?

Thanks.

Coordinator
Aug 12, 2011 at 5:50 PM

Yes it should be fixed in 0.9.1, unless I fixed something else ….

If you take the new version, you don’t need to change anything.

We can continue offline if you prefer, for efficiency.

Aug 12, 2011 at 7:40 PM

Still having problem, sent you an email.

Aug 12, 2011 at 9:35 PM

My problem is now fixed thanks to Sebastien :-)

Oct 4, 2011 at 10:59 AM

I'm also having an upgrade problem ... upgrade to 0.9.1 (from 0.2.2), there were some messages about now being able to overwrite files, but the upgrade said it ran successfully ... now I'm getting errors about missing columns. What was the solution for JonnyBoats?

Oct 4, 2011 at 11:11 AM

Ok, I got it working again (had to disable the module to log in, then re-enabled it and ran the update again).